How to completely turn OFF wrapping of long lines

Ask how to do things or if a certain feature is available in the program.
Post Reply
karl.ranseier
Posts: 4
Joined: 28 Jan 2019 11:17

How to completely turn OFF wrapping of long lines

Post by karl.ranseier »

I have some files with very long lines but I do not want them to be wrapped.

I can't find the option that turns this off.

The "Word Wrap" option in the "General" section only offers different types of wrapping, but no option to turn it off completely.

I selected "Word wrap at #column" and entered 99999 as the column number, but my line (1360 characters, no whitespace) is still wrapped.

Those are XML files if that makes any difference.

I am using v14.70 on Windows 10

User avatar
pjj
Posts: 1853
Joined: 13 Oct 2009 13:48
Location: Kraków, Poland

Re: How to completely turn OFF wrapping of long lines

Post by pjj »

View > Word wrap or Ctrl+W.

You may want to switch off "Turn on wordwrap" in Options > File > Open, and also "Always set word wrap for new documents" (if it is on).
Alium tibi quaere fratrem; hic, quem tuum putas, meus est. Titus Flāvius Caesar Vespasiānus Augustus

karl.ranseier
Posts: 4
Joined: 28 Jan 2019 11:17

Re: How to completely turn OFF wrapping of long lines

Post by karl.ranseier »

Thanks for the quick reply.

When turn it off through "View -> Word wrap" it's better: now it displays the long line in two lines instead of 15. But still a single line would be better (otherwise the XML looks really confusing)

> You may want to switch off "Turn on wordwrap" in Options > File > Open, and also "Always set word wrap for new documents" (if it is on).

Both are already turned off

User avatar
pjj
Posts: 1853
Joined: 13 Oct 2009 13:48
Location: Kraków, Poland

Re: How to completely turn OFF wrapping of long lines

Post by pjj »

I managed to produce xml file with 78k+ chars line's length, but working on it with word-wrap off is virtually impossible for me (it's way better without XML highlighter on, though). I guess RJ TE hasn't been optimized for such, well, unusual cases.

Anyway, two consecutive ^W can unwrap long lines that were automatically wrapped in spite of word-wrap set off.
Alium tibi quaere fratrem; hic, quem tuum putas, meus est. Titus Flāvius Caesar Vespasiānus Augustus

User avatar
Rickard Johansson
Site Admin
Posts: 6091
Joined: 19 Jul 2006 14:29

Re: How to completely turn OFF wrapping of long lines

Post by Rickard Johansson »

You can set the maximum line length in options (Options->Display->Max column width) to anything you want.

karl.ranseier
Posts: 4
Joined: 28 Jan 2019 11:17

Re: How to completely turn OFF wrapping of long lines

Post by karl.ranseier »

Rickard Johansson wrote:
20 Feb 2021 08:46
You can set the maximum line length in options (Options->Display->Max column width) to anything you want.
The maximum value possible is 16384 - but I can live with two lines. As I don't work with those files on a daily basis

Post Reply